import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bkey=\")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?=\")";
final String string = "I found the key=\"abcd-qwer-qaa-xyz-vwxc\" to salvation\n"
+ "I found the key=\"abcd-qwer-qaa-xy-vwxc\" to salvation\n"
+ "I found the key=\"abc-qwer-qaa-xyz-vwxc\" to salvation\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}