import re
regex = re.compile(r"(?<=\bkey=\")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?=\")", flags=re.MULTILINE)
test_str = ("I found the key=\"abcd-qwer-qaa-xyz-vwxc\" to salvation\n"
"I found the key=\"abcd-qwer-qaa-xy-vwxc\" to salvation\n"
"I found the key=\"abc-qwer-qaa-xyz-vwxc\" to salvation\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")