using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\S\s]+?)\s+([\d-\s]*?)\s*([\w])?$";
string input = @"Teststraße 1-5a
Teststraße 5 a
Test Von Tobel Strasse 13 - 16 a";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}