import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\S\\s]+?)\\s+([\\d-\\s]*?)\\s*([\\w])?$";
final String string = "Teststraße 1-5a\n"
+ "Teststraße 5 a\n"
+ "Test Von Tobel Strasse 13 - 16 a";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}