// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([\S\s]+?)\s+([\d-\s]*?)\s*([\w])?$").unwrap();
let string = "Teststraße 1-5a
Teststraße 5 a
Test Von Tobel Strasse 13 - 16 a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}