package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([\S\s]+?)\s+([\d-\s]*?)\s*([\w])?$`)
var str = `Teststraße 1-5a
Teststraße 5 a
Test Von Tobel Strasse 13 - 16 a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}