import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)?/[1-9]\\d+(?!.*(\\d+(?:\\.\\d+)?/[1-9]\\d+))";
final String string = "Happy 4/20 from the team! 13/10 congrats..after so many contents";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}