use strict;
my $str = 'Happy 4/20 from the team! 13/10 congrats..after so many contents';
my $regex = qr`\d+(?:\.\d+)?/[1-9]\d+(?!.*(\d+(?:\.\d+)?/[1-9]\d+))`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}