$re = '`\d+(?:\.\d+)?/[1-9]\d+(?!.*(\d+(?:\.\d+)?/[1-9]\d+))`m';
$str = 'Happy 4/20 from the team! 13/10 congrats..after so many contents';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);