re = /\d+(?:\.\d+)?\/[1-9]\d+(?!.*(\d+(?:\.\d+)?\/[1-9]\d+))/m
str = 'Happy 4/20 from the team! 13/10 congrats..after so many contents'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end