const regex = new RegExp('\\d+(?:\\.\\d+)?/[1-9]\\d+(?!.*(\\d+(?:\\.\\d+)?/[1-9]\\d+))', 'gm')
const str = `Happy 4/20 from the team! 13/10 congrats..after so many contents`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}