using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B#([\p{L}\p{N}_]+)(?!#)\b";
string input = @"https://google.com/#test #asdasd
#test
#你好
#asdasdasd .#asdasd #asdasd#asdasd
Works well for most languages. And requires a space in front.
##no <-- not allowed which is good.
#yes
#güneş
#günşöhlesi
Not sure why some say languages like the one above doesn't work...
https://github.com/justoverclockl/flarum-ext-hashtag####hashtag
#asdasd.
#123123123+asdasd";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}