re = /\B#([\p{L}\p{N}_]+)(?!#)\b/
str = 'https://google.com/#test #asdasd
#test
#你好
#asdasdasd .#asdasd #asdasd#asdasd
Works well for most languages. And requires a space in front.
##no <-- not allowed which is good.
#yes
#güneş
#günşöhlesi
Not sure why some say languages like the one above doesn\'t work...
https://github.com/justoverclockl/flarum-ext-hashtag####hashtag
#asdasd.
#123123123+asdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end