import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"\B#([\p{L}\p{N}_]+)(?!#)\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #####"""
https://google.com/#test #asdasd
#test
#你好
#asdasdasd .#asdasd #asdasd#asdasd
Works well for most languages. And requires a space in front.
##no <-- not allowed which is good.
#yes
#güneş
#günşöhlesi
Not sure why some say languages like the one above doesn't work...
https://github.com/justoverclockl/flarum-ext-hashtag####hashtag
#asdasd.
#123123123+asdasd
"""#####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)