using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ServiceInvoker\s+\((?<service_name>\w+)\)\s+:\s+(?<service_flow>\w+)\s+:[^=]+=\s(?<response_time>\d+)";
string input = @" ServiceInvoker (serviceA) : executeFlow : Time Take is = 3378 ms
ServiceInvoker (serviceB) : executeFlow : Time Take is = 378 ms
ServiceInvoker (serviceC) : executeFlow : Time Take is = 338 ms";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}