// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ServiceInvoker\s+\((?<service_name>\w+)\)\s+:\s+(?<service_flow>\w+)\s+:[^=]+=\s(?<response_time>\d+)").unwrap();
let string = " ServiceInvoker (serviceA) : executeFlow : Time Take is = 3378 ms
ServiceInvoker (serviceB) : executeFlow : Time Take is = 378 ms
ServiceInvoker (serviceC) : executeFlow : Time Take is = 338 ms";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}