const regex = /ServiceInvoker\s+\((?<service_name>\w+)\)\s+:\s+(?<service_flow>\w+)\s+:[^=]+=\s(?<response_time>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ServiceInvoker\\s+\\((?<service_name>\\w+)\\)\\s+:\\s+(?<service_flow>\\w+)\\s+:[^=]+=\\s(?<response_time>\\d+)', 'gm')
const str = ` ServiceInvoker (serviceA) : executeFlow : Time Take is = 3378 ms
ServiceInvoker (serviceB) : executeFlow : Time Take is = 378 ms
ServiceInvoker (serviceC) : executeFlow : Time Take is = 338 ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}