re = /ServiceInvoker\s+\((?<service_name>\w+)\)\s+:\s+(?<service_flow>\w+)\s+:[^=]+=\s(?<response_time>\d+)/m
str = ' ServiceInvoker (serviceA) : executeFlow : Time Take is = 3378 ms
ServiceInvoker (serviceB) : executeFlow : Time Take is = 378 ms
ServiceInvoker (serviceC) : executeFlow : Time Take is = 338 ms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end