$re = '/ServiceInvoker\s+\((?<service_name>\w+)\)\s+:\s+(?<service_flow>\w+)\s+:[^=]+=\s(?<response_time>\d+)/m';
$str = ' ServiceInvoker (serviceA) : executeFlow : Time Take is = 3378 ms
ServiceInvoker (serviceB) : executeFlow : Time Take is = 378 ms
ServiceInvoker (serviceC) : executeFlow : Time Take is = 338 ms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);