import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^NODE_([0-9]+)_.*_([0-9]+)";
final String string = "NODE_1_length_59711_cov_84.026979_g0_i0_1 12.8\n"
+ "NODE_1_length_59711_cov_84.026979_g0_i0_2 18.9\n"
+ "NODE_2_length_59711_cov_84.026979_g0_i0_1 14.3\n"
+ "NODE_2_length_59711_cov_84.026979_g0_i0_2 16.1\n"
+ "NODE_165433_length_59711_cov_84.026979_g0_i0_1 29";
final String subst = "$1_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}