import re
regex = re.compile(r"^NODE_([0-9]+)_.*_([0-9]+)", flags=re.MULTILINE)
test_str = ("NODE_1_length_59711_cov_84.026979_g0_i0_1 12.8\n"
"NODE_1_length_59711_cov_84.026979_g0_i0_2 18.9\n"
"NODE_2_length_59711_cov_84.026979_g0_i0_1 14.3\n"
"NODE_2_length_59711_cov_84.026979_g0_i0_2 16.1\n"
"NODE_165433_length_59711_cov_84.026979_g0_i0_1 29")
subst = "$1_$2"
result = regex.sub(subst, test_str)
if result:
print(result)