const regex = /^NODE_([0-9]+)_.*_([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^NODE_([0-9]+)_.*_([0-9]+)', 'gm')
const str = `NODE_1_length_59711_cov_84.026979_g0_i0_1 12.8
NODE_1_length_59711_cov_84.026979_g0_i0_2 18.9
NODE_2_length_59711_cov_84.026979_g0_i0_1 14.3
NODE_2_length_59711_cov_84.026979_g0_i0_2 16.1
NODE_165433_length_59711_cov_84.026979_g0_i0_1 29`;
const subst = `$1_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);