package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\.*$`)
var str = `python...is...fun...
python...is...fun
python...is...fun??`
var substitution = "."
fmt.Println(re.ReplaceAllString(str, substitution))
}