const regex = new RegExp('\\b\\.*$', 'gm')
const str = `python...is...fun...
python...is...fun
python...is...fun??`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);