import re
regex = re.compile(r"\b\.*$", flags=re.MULTILINE)
test_str = ("python...is...fun...\n"
"python...is...fun\n"
"python...is...fun??")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)