re = /\b\.*$/m
str = 'python...is...fun...
python...is...fun
python...is...fun??'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result