$re = '/\b\.*$/m';
$str = 'python...is...fun...
python...is...fun
python...is...fun??';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;