#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]+(\.[0-9]{2})?\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\s+"Description")?"
Local $sString = "62.00|LQ+2*2,FP,MD*3 "Description"" & @CRLF & _
"62|LQ+2*2,FP,MD*3 "Description"" & @CRLF & _
"62|LQ+2*2,FP,MD*3" & @CRLF & _
"62|LQ*2,FP,MD*3" & @CRLF & _
"62|LQ+8,FP,MD*3" & @CRLF & _
"62|LQ,FP,MD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")