const regex = /[0-9]+(\.[0-9]{2})?\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\s+"Description")?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+(\\.[0-9]{2})?\\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\\s+"Description")?', 'gm')
const str = `62.00|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3
62|LQ*2,FP,MD*3
62|LQ+8,FP,MD*3
62|LQ,FP,MD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}