use strict;
my $str = '62.00|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3
62|LQ*2,FP,MD*3
62|LQ+8,FP,MD*3
62|LQ,FP,MD';
my $regex = qr/[0-9]+(\.[0-9]{2})?\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\s+"Description")?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}