package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\${(\s*((?<rewriter>[^(\s]+)\s*\(\s*(?<key>[^()?\s}]+)\s*\)\s*)|(\s*(?<key>[^()?\s}]+)\s*))(\?(?<fallback>[^}]*))*}`)
var str = `${func(key)?default}
${func(} should not match
${func(key} should not match
${key)} should not match
${key}
${key?}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}