const regex = new RegExp('\\${(\\s*((?<rewriter>[^(\\s]+)\\s*\\(\\s*(?<key>[^()?\\s}]+)\\s*\\)\\s*)|(\\s*(?<key>[^()?\\s}]+)\\s*))(\\?(?<fallback>[^}]*))*}', 'gm')
const str = `\${func(key)?default}
\${func(} should not match
\${func(key} should not match
\${key)} should not match
\${key}
\${key?}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}