re = /\${(\s*((?<rewriter>[^(\s]+)\s*\(\s*(?<key>[^()?\s}]+)\s*\)\s*)|(\s*(?<key>[^()?\s}]+)\s*))(\?(?<fallback>[^}]*))*}/m
str = '${func(key)?default}
${func(} should not match
${func(key} should not match
${key)} should not match
${key}
${key?}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end