# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^ ])\1{2,}/$1$1/gm;t' <<< "who wrote huckleby never f****** mind i see right there ----> who wrote huckleby never f** mind i see right there
burger king net neutralityyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
when was the little prince book published?aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"