use strict;
my $str = 'who wrote huckleby never f****** mind i see right there ----> who wrote huckleby never f** mind i see right there
burger king net neutralityyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
when was the little prince book published?aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa';
my $regex = qr/([^ ])\1{2,}/mp;
my $subst = '$1$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";