$re = '/([^ ])\1{2,}/m';
$str = 'who wrote huckleby never f****** mind i see right there ----> who wrote huckleby never f** mind i see right there
burger king net neutralityyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
when was the little prince book published?aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa';
$subst = "$1$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;