using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ ])\1{2,}";
string substitution = @"$1$1";
string input = @"who wrote huckleby never f****** mind i see right there ----> who wrote huckleby never f** mind i see right there
burger king net neutralityyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
when was the little prince book published?aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}