#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^ ])\1{2,}"
Local $sString = "who wrote huckleby never f****** mind i see right there ----> who wrote huckleby never f** mind i see right there" & @CRLF & _
"burger king net neutralityyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy" & @CRLF & _
"when was the little prince book published?aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
Local $sSubst = "$1$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)