using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/site\.com\/([^\/]+\/){3}([^\/]+)\/[^.]+(.*)";
string input = @"https://site.com/content/images/45/1000x1000l80mc0/copy_kvadrokopter-lyzrc-l900-pro-orange-dron-z-4k-i-hd-kamerami-esc-fpv-gps-bk-motori-do-1200m-28-khvilin-50233095308044.webp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}