import Foundation
let pattern = #"https:\/\/site\.com\/([^\/]+\/){3}([^\/]+)\/[^.]+(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://site.com/content/images/45/1000x1000l80mc0/copy_kvadrokopter-lyzrc-l900-pro-orange-dron-z-4k-i-hd-kamerami-esc-fpv-gps-bk-motori-do-1200m-28-khvilin-50233095308044.webp"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)