// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/site\.com\/([^\/]+\/){3}([^\/]+)\/[^.]+(.*)").unwrap();
let string = "https://site.com/content/images/45/1000x1000l80mc0/copy_kvadrokopter-lyzrc-l900-pro-orange-dron-z-4k-i-hd-kamerami-esc-fpv-gps-bk-motori-do-1200m-28-khvilin-50233095308044.webp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}