import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/site\\.com\\/([^\\/]+\\/){3}([^\\/]+)\\/[^.]+(.*)";
final String string = "https://site.com/content/images/45/1000x1000l80mc0/copy_kvadrokopter-lyzrc-l900-pro-orange-dron-z-4k-i-hd-kamerami-esc-fpv-gps-bk-motori-do-1200m-28-khvilin-50233095308044.webp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}