package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(10.0.0.[0-9]{1,3})(\/32)`)
var str = `10.0.0.1/32, 10.0.0.12/32, 10.0.0.123/32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}