// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(10.0.0.[0-9]{1,3})(\/32)").unwrap();
let string = "10.0.0.1/32, 10.0.0.12/32, 10.0.0.123/32";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}