const regex = /(10.0.0.[0-9]{1,3})(\/32)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(10.0.0.[0-9]{1,3})(\\\/32)', 'gm')
const str = `10.0.0.1/32, 10.0.0.12/32, 10.0.0.123/32`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}