$re = '/(10.0.0.[0-9]{1,3})(\/32)/m';
$str = '10.0.0.1/32, 10.0.0.12/32, 10.0.0.123/32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);