#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^)",|"groups":\s*\[)\s*"\K[^"]+"
Local $sString = "{" & @CRLF & _
" "policyItems": [" & @CRLF & _
" {" & @CRLF & _
" "accesses": [" & @CRLF & _
" {" & @CRLF & _
" "type": "submit-app"," & @CRLF & _
" "isAllowed": true" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "users": []," & @CRLF & _
" "groups": [" & @CRLF & _
" "Application_Team_1"," & @CRLF & _
" "team2"" & @CRLF & _
" ]," & @CRLF & _
" "conditions": []," & @CRLF & _
" "delegateAdmin": false" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")