using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)"",|""groups"":\s*\[)\s*""\K[^""]+";
string input = @"{
""policyItems"": [
{
""accesses"": [
{
""type"": ""submit-app"",
""isAllowed"": true
}
],
""users"": [],
""groups"": [
""Application_Team_1"",
""team2""
],
""conditions"": [],
""delegateAdmin"": false
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}