import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)\",|\"groups\":\\s*\\[)\\s*\"\\K[^\"]+";
final String string = "{\n"
+ " \"policyItems\": [\n"
+ " {\n"
+ " \"accesses\": [\n"
+ " {\n"
+ " \"type\": \"submit-app\",\n"
+ " \"isAllowed\": true\n"
+ " }\n"
+ " ],\n"
+ " \"users\": [],\n"
+ " \"groups\": [\n"
+ " \"Application_Team_1\",\n"
+ " \"team2\"\n"
+ " ],\n"
+ " \"conditions\": [],\n"
+ " \"delegateAdmin\": false\n"
+ " }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}