const regex = /(?:\G(?!^)",|"groups":\s*\[)\s*"\K[^"]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)",|"groups":\\s*\\[)\\s*"\\K[^"]+', 'gm')
const str = `{
"policyItems": [
{
"accesses": [
{
"type": "submit-app",
"isAllowed": true
}
],
"users": [],
"groups": [
"Application_Team_1",
"team2"
],
"conditions": [],
"delegateAdmin": false
}
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}